使用或是安装wp主题时,前台提示Parse error: syntax error, unexpected ‘}’ in 的错误代码提示

释放双眼,带上耳机,听听看~!

使用或是安装wp主题时,前台提示Parse error: syntax error, unexpected ‘}’ in 的错误代码提示,这是大挖客户遇到的问题,通过截图可以看到,他使用的是大挖的,挖链主题。客户使用的服务器是标准的宝塔构架,可以说后面功能很完善,且操作设置很方便。大挖进入到服务器后台进入到网站-设置-php版本-调整了版本为PHP5.5。这个问题就解决了。
2019042209435880.png插图
简单讲解一下原因,对于PHP开发人员来讲,这此段提示代码只是兼容性错误的一个判断,及对应文件的一个识别误判,我们知道对于WordPress程序来讲,最低配置的php版本为5.2但是想要正常的使用WordPress完整的功能,需要标配的php5.4以上版本,所以wordpresser在建站过程中一旦出现先去调整下php的版本设置,对于常见的虚拟云服务商都是有此功能的。

给TA打赏
共{{data.count}}人
人已打赏

相关文章

小工具

防摸鱼神器,试试这款便携的局域网屏幕监控工具!

2023-9-23 11:41:24

WordPressWP代码网页建站

给你的wordpress配置伪静态页面文章.html后缀

2023-1-18 18:13:09

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索